from pyecharts import options as opts报错问题以及解决办法

  • 时间:
  • 来源:互联网
  • 文章标签:

from pyecharts import options as opts报错问题
pyecharts是一个十分强大的python绘图库,但是使用过程中或多或少遇到一些问题,今天笔者在使用pyecharts导入options包时就遇到无法导入的问题。
问题分析:
其实这是pyecharts版本不匹配导致的,笔者使用的是pyecharts0.1.9.4的版本,然而options包是在pyecharts1.x 以上的版本才有的。通过查看官方文档发现,pyecharts v0.5.X和v1版本之间是不兼容的。下图是官方文档给版本简介。
在这里插入图片描述
所以如果想使用options包,只能卸载当前版本,重新安装V1以上的版本。

解决方法:
1. 卸载原先版本
打开命令提示符,cd进入自己python的安装目录,输入pip uninstall pyecharts,出现如下界面。
在这里插入图片描述
因为我的pyecharts是刚安装的pyecharts35 1.7.1所以我输入的是pip uninstall pyecharts35,根据自己pyecharts版本进行卸载,最后输入y回车即可完成卸载。
2.安装v1.7.1版本
接下来,安装pyecharts 1.7.1版本,pyecharts当前最新的版本是1.8.1,这里强烈建议大家别安装最新的版本,笔者亲测,安装完1.8.1以后导入options包确实不会出问题,但是又会报 " 所有图表类型将在 v1.9.0 版本开始强制使用 ChartItem 进行数据项配置" 这个错误。最终解决办法还是将1.8.1卸载,又安装的1.7.1。因此,最好直接安装1.7.1的版本就可以一劳永逸。
由于官网不给以前的版本,只有最新的版本,可以在这个网站下载1.7.1版本。进入网站点击下载
pyecharts35-1.7.1-py3-none-any.whl,如下图。
在这里插入图片描述
将下载的文件放入自己Python目录Scripts目录里(也可以放入其他目录,记住路径就可以),如下图。
在这里插入图片描述
然后进入命令提示符,cd进入刚放入文件的目录,输入pip
install pyecharts35-1.7.1-py3-none-any.whl回车即可完成安装。如下图。
在这里插入图片描述
下面测试一下,导入from pyecharts import options as opts是否还报错。

from pyecharts import options as opts
from pyecharts.charts import Bar

bar = Bar()
bar.add_xaxis(["衬衫", "羊毛衫", "雪纺衫", "裤子", "高跟鞋", "袜子"])
bar.add_yaxis("商家A", [5, 20, 36, 10, 75, 90])
# render 会生成本地 HTML 文件,默认会在当前目录生成 render.html 文件
# 也可以传入路径参数,如 bar.render("mycharts.html")
bar.render(path="./data/实例.html")

这是一个官网给的例子,运行发现没有报错,在data目录中成功生成"实例.html"文件,点击如下。
在这里插入图片描述

本文链接http://www.taodudu.cc/news/show-1782150.html